The Socialize It! plugin requires WordPress 3.0 or newer. Your version is 1. Please, update your WordPress!